Pending Wont't boot MSI 970 Gaming motherboard AMD FX-6300

  • Be sure to checkout “Tips & Tricks”
    Dear Guest Visitor → Once you register and log-in:

    This forum does not automatically send notices of new content. So if, for example, you would like to be notified by mail when Steve posts an update to his blog (or of any other specific activity anywhere else), you need to tell the system what to “Watch” for you. Please checkout the “Tips & Tricks” page for details about that... and other tips!

    /Steve.

Ali

New member
Sep 30, 2020
3
0
Hello,

I downloaded Read Speed and created a bootable USB, however, when I select the USB in my computer's boot menu, it does not boot to DOS and proceeds to load grub. I have both Win 10 and Linux installed using USB so I know it's possible to boot from USB. My computer is a few years old and the motherboard is set to both UEFI and Legacy.

Thanks,
Ali
 

PHolder

Well-known member
Sep 16, 2020
751
2
352
Ontario, Canada
Is secure boot disabled and the CSM enabled? DOS will not boot without the CSM.

EDIT: Looking at your motherboard manual, it never explicitly mentions the CSM... so that may be troublesome. Searching on "legacy" did bring:
Code:
Legacy USB Support [Enabled]
Sets Legacy USB function support.
[Auto] The system will automatically detect if any USB device is connected
and enables or disables the legacy USB support.
[Enabled] Enable the USB support for legacy operating systems that do not
support USB.
[Disabled] The USB devices are available only for UEFI applications.

I got the manual here: https://www.msi.com/Motherboard/support/970-gaming#down-bios I don't know if you've ever updated your BIOS, but if not that might help (but probably won't.)
 
Last edited:

PHolder

Well-known member
Sep 16, 2020
751
2
352
Ontario, Canada
The CSM is the BIOS compatibility support module. It seems like your BIOS might be one of those ones released early in the transition to UEFI and the terms and features may still have been in flux. Note the edit I did to my post above and check that setting. There may be other settings in your system you'll need to futz with... or it's possible that motherboard just never had true BIOS compatibility. (It may have been tested with Windows and never with DOS.)
 

Ali

New member
Sep 30, 2020
3
0
I believe MSI calls it Legacy mode, which is enabled. There are two options, UEFI and UEFI + Legacy
 

PHolder

Well-known member
Sep 16, 2020
751
2
352
Ontario, Canada
Is it possible that your BIOS is one of those that has two entries for USB devices. One is explicitly for UEFI and one is implicitly for BIOS. (Or the reverse.) Try temporarily disabling all other boot devices leaving only USB (which was installed in the machine before entering the BIOS) and see if there is more than one entry for the same device. Aside from the possibility it may never work, you're probably going to have to futz around until you've tried all the options.
 
  • Like
Reactions: Steve

millQ

Member
Oct 20, 2020
22
7
boot mode select: LEGACY + UEFI?

Maybe you have to change the boot order so it boots legacy USB before UEFI


msi_snapshot_03.jpg
 
Last edited:

PHolder

Well-known member
Sep 16, 2020
751
2
352
Ontario, Canada
You want is what you have at #11 in the picture. You want an option that does NOT have UEFI with it. Move that choice to #1 and disable all the rest if you can.