WD Caviar 31200, 1281MB hard drive with my ancient BBS on it.

  • SpinRite v6.1 Release #3
    Guest:
    The 3rd release of SpinRite v6.1 is published and may be obtained by all SpinRite v6.0 owners at the SpinRite v6.1 Pre-Release page. (SpinRite will shortly be officially updated to v6.1 so this page will be renamed.) The primary new feature, and the reason for this release, was the discovery of memory problems in some systems that were affecting SpinRite's operation. So SpinRite now incorporates a built-in test of the system's memory. For the full story, please see this page in the "Pre-Release Announcements & Feedback" forum.
    /Steve.
  • Be sure to checkout “Tips & Tricks”
    Dear Guest Visitor → Once you register and log-in please checkout the “Tips & Tricks” page for some very handy tips!

    /Steve.
  • BootAble – FreeDOS boot testing freeware

    To obtain direct, low-level access to a system's mass storage drives, SpinRite runs under a GRC-customized version of FreeDOS which has been modified to add compatibility with all file systems. In order to run SpinRite it must first be possible to boot FreeDOS.

    GRC's “BootAble” freeware allows anyone to easily create BIOS-bootable media in order to workout and confirm the details of getting a machine to boot FreeDOS through a BIOS. Once the means of doing that has been determined, the media created by SpinRite can be booted and run in the same way.

    The participants here, who have taken the time to share their knowledge and experience, their successes and some frustrations with booting their computers into FreeDOS, have created a valuable knowledgebase which will benefit everyone who follows.

    You may click on the image to the right to obtain your own copy of BootAble. Then use the knowledge and experience documented here to boot your computer(s) into FreeDOS. And please do not hesitate to ask questions – nowhere else can better answers be found.

    (You may permanently close this reminder with the 'X' in the upper right.)

Fuzzball

Crumudgeonly Old Astronomer
Sep 8, 2023
33
12
California, USA
I'm trying to recover data from an old WD Caviar 31200, 1281MB hard drive. It probably hadn't spun since 1998 and contains a backup of my old BBS machine on it. It's not mission critical but there's a nostalgia factor involved. I ran a FidoNet BBS from 1990 to 2000. Fun times!

The drive MIGHT be formatted with Novell Netware 3.12 or 3.2, which is a NWFS format... apparently a modified FAT. Could also be FAT or FAT32. Almost certainly not NTFS, though I did have some NT machines then. Frankly I'm not sure what it is nor how to tell definitively without mounting it successfully in an OS and have the OS report.

I think the internal controller may be sketchy as it hasn't been found reliably by Spinrite, though Windows and Linux had at least recognized that it was plugged in. I hadn't been trying to "access" it yet... just carefully seeing if anything wants to walk on in. :)

So after many tries I FINALLY got Spinrite to see it while booted on my Zimaboard using a PCIe to IDE card. It refused to recognize it for many tries until I tried while having two other SATA drives plugged in at the same time, along with the USB stick that has Spinrite.

I ran it on level two and it breezed through with no problems found. So I ran it on level 4. No issues.

So then I booted Zimaboard to Windows 10 and looked in Disk Management. I see it there as "Disk 3, Basic, 1.19 GB, Online." It says "Healthy (Primary Partition). If I go to properties/volumes it says Partition Style: Master Boot Record (MBR).

It doesn't have a drive letter. If I right click on the left section it offers to Convert to Dynamic Disk. If I right click to the right, on the partition part, it offers to Delete Volume and that's it.

I backed out of that and booted to CasaOS (Zimaboard's native Linux) and mounted the drive. Yes... I thought I was home free!!! I can see folders and file names. And they look normal. But when I try to access them it says they're corrupted and shows crazy 8 bit info in the names on the error screen, though those 8 bit names don't show when just browsing. Only when accessing. If I try to access anything beyond 2nd level directories I get the errors. Unfortunately everything is beyond 2nd level directories. (The root of the drive has a folder called \1998\ and in there is a basic C: drive backup. A DOS folder, a Windows folder, etc.)

I now see that Linux tools are reporting it's a Partition Type 0x65, FAT (16 bit version). And as Linux is looking at the drive properties it's trying to count up the data size and number of files. It has now counted > 100k files totaling 20TB, which of course isn't possible. I guess the FAT has some sort of nested loop.

The only Netware 3.12 media I have are ancient floppies, and I have no way to access those, assuming they were even viable.

Is it possible this is a healthy Netware NWFS file system that just needs to be mounted as a NWFS partition?
 

Attachments

  • WD Caviar 31200.txt
    9.3 KB · Views: 43
Good luck in retrieving the data. I too used to run a BBS myself back in the 90s. Renegade/Intermail/Fidnet/ITCNet.
 
Wikipedia says NWFS is based on a heavily modified version of FAT so that might explain your findings.
 
If I get some time this weekend I'll give HDDSuperClone and Captain Nemo a try.

I wonder if Netware is open source these days? I guess I could get a USB floppy drive and see if my old Netware install disks are viable. Honestly, I'd like to have a Netware VM just for nostalgic purposes. I still occasionally fire up Windows 1 or 3.1 or OS/2 VM's just for kicks. I think I just like to revel in how FAST they boot up. :) I've never put together a Novell Netware VM, which surprises me since I used to live by it back in the 90's.