Closed Strange Issues with PC After ReadSpeed Use

  • Be sure to checkout “Tips & Tricks”
    Dear Guest Visitor → Once you register and log-in:

    This forum does not automatically send notices of new content. So if, for example, you would like to be notified by mail when Steve posts an update to his blog (or of any other specific activity anywhere else), you need to tell the system what to “Watch” for you. Please checkout the “Tips & Tricks” page for details about that... and other tips!

    /Steve.

merk

Member
Sep 19, 2020
8
3
USA
Hey @Steve

I was in the middle of typing a very long convoluted message and decided to delete it all and restart with something much simpler. I have had a day of troubleshooting USB problems on my computer and it all started this morning with running ReadSpeed. I'm not sure if that is related to my issues or just a coincidence. If you would like more explanation, I am happy to describe everything to the best that I remember it. The short version is that the USB key I installed ReadSpeed on no longer functions, Windows 10 hung while rebooting a few times, my front USB ports stopped working for a while, and as a result of that I think that my USB drivers have reinstalled at least once if not twice today. At some point during the mess, I tried using Initdisk and that froze up as well. At first, I thought that Initdisk was leading to my USB issues, but I actually just ran it a minute ago and it seems to work now.

- Shawn
 

Steve

(as in GRC)
Staff member
Feb 1, 2019
377
1
1,000
66
Southern CA, USA
www.grc.com
@merk - Shawn: Hmm. Well, at this point we don't have a HUGE amount of experience with ReadSpeed and InitDisk, though they have both been extensively tested for months by many in the GRC newsgroups. So all I can say is that at no point has anyone reported any trouble like you experienced today. I appreciate the report in case we see something like this again.
 
  • Like
Reactions: Barry Wallis

pmikep

Well-known member
Dec 26, 2020
60
9
It's winter time (at least here in the Northern Hemisphere). Sounds like ESD.
 

merk

Member
Sep 19, 2020
8
3
USA
It's winter time (at least here in the Northern Hemisphere). Sounds like ESD.
Yeah, I'm pretty sure it was a coincidence that the key stopped working. I should have mentioned it before, but I omitted this due to the post getting too long - I also tried running a Seagate utility on an external USB drive and now that I think about it, that's when I first started having the USB trouble. I noticed that the thumb drive I used with ReadSpeed was not working when I tried to install the Seagate utility on it. I tried to use Initdisk on it, thinking my PC just wasn't reading it for some reason. That's when Initdisk froze and I realized I had all the USB trouble. Then after restoring my USB drivers and ports, the same thumb drive did not work. I had another one and the Seagate utility installed fine on it. Then I put ReadSpeed on that one afterward too. Computers :cautious:
 
  • Like
Reactions: Steve

selwynpolit

Member
Dec 28, 2020
9
0
@merk I also have a windows 10 PC that has some weird behaviour when it comes to the usb ports - only if I try to plug in a thumb drive. Strangely, it also doesn't want to access its two DVD burners that are in it either. It just freezes up and requires a hard restart to get back up. usb printing and usb scanning work fine but anything involving a usb thumb drive just pisses it off. Curiously I am able to backup to an external spinning drive (using Image for Windows) with no surprises. I'm very curious if you come up with a solution. I need to try booting it off a thumb drive or Linux boot CD and see if it behaves (if it is hardware or software)

Now I'm wondering if it is only the front usb ports that are a problem. ???

Computers can be such fun!
 

PHoganDive

Member
Sep 30, 2020
23
11
Back in the old days of computers, when they ran DOS, you had to manually set up the devices via autoexec.bat and config.sys files, to assign them port numbers, base addresses, IRQ numbers, etc so they didn't conflict with each other or other hardware in the system. More modern systems do this automatically, under the hood with newer OS's. Since ReadSpeed runs under DOS, I'm wondering if there might not be a conflict of resources of some kind going on that only occurs if you use a USB port for certain things.
 

selwynpolit

Member
Dec 28, 2020
9
0
Yeah, I vaguely remember those days. That tower computer of mine is apparently just ready for the dumpster. I think something went goofy with the motherboard. Perhaps a reflash of the BIOS is in order

I'm trying to decide if I want to get a new mobo and rebuild or get a used dell. Mostly a question of how much time I want to devote to it.

@merk did you ever get your system to settle down?
 

merk

Member
Sep 19, 2020
8
3
USA
@selwynpolit My system has not been a problem since I posted a few days ago. I don't use usb keys that often though. I have had a range of other devices plugged into my front ports though and have had absolutely zero issues with them. Right now, just for kicks, I ran the readspeed installer, put it on a thumb drive, removed the drive and plugged it back in to see if it recognized it. Everything went smooth and no problems. I really think that the Seagate Utility is what screwed up my whole system. Once I reinstalled the USB drivers by removing the USB devices in Device Manager, everything started working correctly again.
 

SeanBZA

Active member
Oct 1, 2020
41
6
No need to reflash the BIOS, simpler to go into the BIOS and load the optimal or default values, which will restore the as factory settings. Then you can just save and exit, or customise any settings ( like boot order, splash screen or any overclocking you have) before doing so, but probably best to see if default settings get you running correctly first, then do the customising.

Only time you really reflash is if you have an old version with known bugs, and the new version has at least been out long enough to have most of the errata known, or want any microcode upgrades that came with the new version.
 

selwynpolit

Member
Dec 28, 2020
9
0
@merk Glad you got it all working. My PC also got all better when I removed both the DVD burners that had decided to go bad. Now all my USB ports work predictably. I guess windows just got stuck retrying accessing the DVD drives and that manifested with USB thumbdrives. So weird that they both died. I tried them in another computer and also tried another DVD burner in this PC and they were definitely dead - the other DVD burner was fine in my computer. It's like a soap opera. ;-)