Closed ReadSpeed won't Boot on X35G

  • Release Candidate 6
    Guest:
    We are at a “proposed final” true release candidate with nothing known remaining to be changed or fixed. For the full story, please see this page in the "Pre-Release Announcements & Feedback" forum.
    /Steve.
  • Be sure to checkout “Tips & Tricks”
    Dear Guest Visitor → Once you register and log-in:

    This forum does not automatically send notices of new content. So if, for example, you would like to be notified by mail when Steve posts an update to his blog (or of any other specific activity anywhere else), you need to tell the system what to “Watch” for you. Please checkout the “Tips & Tricks” page for details about that... and other tips!

    /Steve.

PaulZ

Member
Oct 1, 2020
8
1
I have a new SFF computer made by Minisforum, their X35G. It sports an Intel Core i3 1005G1 Processor and 16 GB DDR4 of memory. My plan was to use it for a pfsense box since it has dual Gigabit Ethernet ports. But its BIOS is very odd, with almost no settings. I'm able to load Win10 on the NVMe vis a USB flash drive. However, when I try to install multiple Linux OS' they don't recognize the SSD.

So, I've been running through Linux distros, seeing what the issues are with each. I install the distro on various USB drives then boot from them on the X35G. I tried to run a ReadSpeed formatted flash drive and it fails to even boot. I've only had that problem with one other OS; PMagic v2013_08_01.

On this computer you have to install the flash drive, enter the BIOS screen and set the boot order to the flash drive by name (this is how they are listed):

  • Windows Boot Manager (Samsung SSD 950 PRO 512GB)
  • UEFI: Innostar Innostor 1.00
  • UEFI: Imation USB Flsah Drive 0.00
I've the initial failure I have installed ReadSpeed on 4 other USB flash drives and none of them will boot. They are all recognized initially by the BIOS but won't run. The flash drives are good, as I've booted different Linux distros off of them in my trials.

From the X35G BIOS screen:

<At the top of the screen> Apito Setup - American Megatrends International
BIOS Version: IB9_8GV110
Build Date and Time: 11/05/2020 16:22:54
EC Version: 00.03.02
Manufacturer Name: Besstar Tech Limited <interesting it isn't Minisforum>
<At the bottom of the screen> Ver. 2.21.1277 Copyright (c) 2020 American Megatrends International

Paul
 
@PaulZ : Are you certain that the machine has a BIOS bios and not a UEFI bios? From what you posted, it looks like a UEFI-based machine. I suppose it's possible for it to be both, but it doesn't look like it. ReadSpeed runs on DOS and BIOS, and DOS only runs on BIOS-based machines. So my guess would be that yours is a UEFI-based machine, which will not (yet) run ReadSpeed.

Support for UEFI is considered critical, but getting something running for SpinRite's traditional BIOS-based systems needs to come first. So we ill get there... but we're not there yet.
 
  • Like
Reactions: Barry Wallis
@Steve, so how do I tell the difference between BIOS and UEFI? Since, this is a brand new machine, I'll guess it is the latter.
 
how do I tell the difference between BIOS and UEFI
Ideally it will say... but UEFI is usually more graphical, and may even support a mouse.
 
@Steve, so how do I tell the difference between BIOS and UEFI? Since, this is a brand new machine, I'll guess it is the latter.
I'll bet you're right, Paul. New == UEFI. This is why I've change my priorities around to move UEFI up to the next thing I tackle. SpinRite is going to be needing it sooner or later, so the sooner the better!
 
  • Like
Reactions: Barry Wallis
@Steve I don't know, the screen looks old school, text based not a GUI.
20201215_031515885_1.jpg
 
What does the Boot screen show? That's where the boot info will be.

Yeah, it does look "old school" but the copyright is 2020 - new!
 
Yes, that definitely looks like a BIOS to me. I tried looking on Minisforum for a manual, but that was futile (doesn't make me ever want to do business with them.)

Anyway, look to see if you can do any of these things (or send pictures of the other tabs in BIOS.)
- Disable secure boot
- Enable CSM
- Mount the USB stick then look on the boot page for a boot order and see if it is listed there and make it your first bootable item

Also your clock/date seems pretty off. ;)
 
@PaulZ

Not your Motherboard..but
40 seconds in the video
CSM module enable

MINISFORUM H31G BIOS​


MINISFORUM X35G BIOS​



Do you have the advanced menu in your X35G BIOS?
 
@PHolder and @millQ , thanks for your suggestions. But all it has done is made me feel bad for my poor little X35G. It has almost NO BIOS options.

Screen 1: Change date and time
BIOS-1.0_20210103_001839007_sm.jpg
Screen 2: Set Admin PW, User PW and Secure Boot (disabled)
BIOS-2.0_20210103_002112298_sm.jpg
Screen 3: Set Boot Priorities (only of currently recognized devices), Wake on Lan, Fast Boot, S5 RTC Wake & PXE.
BIOS-3.0_20210102_180539076_sm.jpg
Screen 4: Save & Exit, Discard Changes & Restore Defaults.
BIOS-4.0_20210103_002210923_sm.jpg

That's all that's in the BIOS.
I really like this form factor, with a nice CPU and dual gigabit Ethernet. But it seems crippled for anything other than Windows.
 
@PaulZ This may work. use for what it's worth. My laptop has an AMI bios similar to yours, but much older. If I hold the magic key (ESC on mine, yours may be different) while powering up (or maybe after power up on some) and wait for the logo then release ESC, enter password, I can get into a menu. This will show me my boot options. Initially, that doesn't show the USB as bootable. But, if I put the ReadSpeed USB in BEFORE powering up, then go through this procedure, it shows up on the boot menu and I can select it. The 3rd image below is the first run through without the USB in at power up. The 4th image below is the 2nd run through with the USB in at power up. Hope it helps.

IMG_20210102_201221420.png


IMG_20210102_201227558.png


IMG_20210102_201246410.png


IMG_20210102_201328427.png


May your bits be stable and your interfaces be fast. :cool: Ron
 
Last edited:
@PHolder & @DanR , On screen 3 the boot configuration will only list devices that have something attached to them on the current boot. That is, there is there are 4 USB ports, if you have 4 bootable devices in them, all of them will be listed. Here is an example with an NVMe installed (950 PRO) and two USB flash drives.
20210102_180736584_sm.jpg


But the empty SSD M.2 (in addition to the M.2 NVMe slot) will not be listed if nothing is there on booting.

The second boot option will present you with the same options as the first.
 
Yeah if it says UEFI: in front of the device name, then it is only going to try a UEFI boot. So unless there is some hidden option to enable legacy boot, you're not booting DOS. (Presumably then the UEFI would say something else, or at least not be present.)

I keep reading about pressing ESC (presumable quickly during power on/POST.) Have you tried this, and does it give you a boot menu?

In some ASUS firmwares (e.g. "Aptio"), there is no such global choice – all available boot options are merged into a single menu (press Esc to open the boot menu one-time).

BIOS-mode boot entries always describe a specific disk rather than a specific OS (since they only boot the MBR 'bootcode' and don't know the OS name, unlike UEFI-mode boot entries which do). Of course, it's not impossible that an UEFI boot entry would be named after a disk, but that's rather unlikely...

For removable media, UEFI-mode entries also have an UEFI: prefix, while BIOS-mode entries either don't (as in your case) or are prefixed with BIOS: (on some other computers).
 
Yeah if it says UEFI: in front of the device name, then it is only going to try a UEFI boot. So unless there is some hidden option to enable legacy boot, you're not booting DOS. (Presumably then the UEFI would say something else, or at least not be present.)

I keep reading about pressing ESC (presumable quickly during power on/POST.) Have you tried this, and does it give you a boot menu?
@PHolder, the UEFI you see in front of the device names are what the BIOS sees on the USB Flash Drive, not what type of BIOS is running. In the above case, I had two USB flash drives installed, one by Innostor and the other by Imation. But I did just notice, that the USB flash drive formatted by ReadSpeed is not detected.
 
@PaulZ those are indications of how the device will be booted. I have UEFI machines that can do legacy boot, and on my machines there will be two entries for a USB stick, something like "UEFI Lexar USB" and then "Lexar USB" and since I know I NEVER use UEFI on a USB device, I never select the UEFI option for USB devices when choosing to boot them. Unfortunately it's not a standard on all UEFIs how they will indicate this if they support legacy boot at all. It would be really nice if you could just look at a UEFI/BIOS screen and just know everything it did or did not support.