problem booting Lenovo desktop to USB flash drive

  • Release Candidate 6
    Guest:
    We are at a “proposed final” true release candidate with nothing known remaining to be changed or fixed. For the full story, please see this page in the "Pre-Release Announcements & Feedback" forum.
    /Steve.
  • Be sure to checkout “Tips & Tricks”
    Dear Guest Visitor → Once you register and log-in:

    This forum does not automatically send notices of new content. So if, for example, you would like to be notified by mail when Steve posts an update to his blog (or of any other specific activity anywhere else), you need to tell the system what to “Watch” for you. Please checkout the “Tips & Tricks” page for details about that... and other tips!

    /Steve.

MichaelRSorg

Well-known member
Nov 1, 2020
107
17
routersecurity.org
A Lenovo ThinkCentre M90n did not boot to the USB flash drive with ReadSpeed after making the most obvious changes: enabling the USB HDD as the first bootable thing and disabling secure boot. BIOS is from American Megatrends (version 2.20.somethinglong)

The next likely BIOS option to change is CSM - Compatibility Support Module which is Disabled by default. But, it would not let me Enable CSM without first disabling something called the Windows Modern Standby. I am way over my head here. The description of Windows Modern Standby says it is not supported without re-installing Windows. Don't need to risk Windows not booting.

Any suggestions? Thanks in advance.
 
Don't need to risk Windows not booting
Well you're not going to boot Windows, because ReadSpeed only runs on DOS. So note your existing configuration of the system BIOS settings, make the necessary changes to get it to boot (you DO need CSM enabled) and then boot DOS, run ReadSpeed. Then undo your changes and boot Windows again.

Specifically what the CSM is, is basically the legacy BIOS. Your PC can boot (was/is booting) UEFI for Windows. UEFI and CSM are mutually exclusive, you either run in legacy mode or you don't. To get a DOS to boot, you need legacy mode, so you need to enable the CSM.
 
  • Like
Reactions: MichaelRSorg