Issues running SpinRite 6.1 Rel 2 on Zimaboard

  • SpinRite v6.1 Release #3
    Guest:
    The 3rd release of SpinRite v6.1 is published and may be obtained by all SpinRite v6.0 owners at the SpinRite v6.1 Pre-Release page. (SpinRite will shortly be officially updated to v6.1 so this page will be renamed.) The primary new feature, and the reason for this release, was the discovery of memory problems in some systems that were affecting SpinRite's operation. So SpinRite now incorporates a built-in test of the system's memory. For the full story, please see this page in the "Pre-Release Announcements & Feedback" forum.
    /Steve.
  • Be sure to checkout “Tips & Tricks”
    Dear Guest Visitor → Once you register and log-in please checkout the “Tips & Tricks” page for some very handy tips!

    /Steve.
  • BootAble – FreeDOS boot testing freeware

    To obtain direct, low-level access to a system's mass storage drives, SpinRite runs under a GRC-customized version of FreeDOS which has been modified to add compatibility with all file systems. In order to run SpinRite it must first be possible to boot FreeDOS.

    GRC's “BootAble” freeware allows anyone to easily create BIOS-bootable media in order to workout and confirm the details of getting a machine to boot FreeDOS through a BIOS. Once the means of doing that has been determined, the media created by SpinRite can be booted and run in the same way.

    The participants here, who have taken the time to share their knowledge and experience, their successes and some frustrations with booting their computers into FreeDOS, have created a valuable knowledgebase which will benefit everyone who follows.

    You may click on the image to the right to obtain your own copy of BootAble. Then use the knowledge and experience documented here to boot your computer(s) into FreeDOS. And please do not hesitate to ask questions – nowhere else can better answers be found.

    (You may permanently close this reminder with the 'X' in the upper right.)

the_physio

Active member
Feb 15, 2023
33
10
Brisbane
I’ve set up a Zimaboard with FreeDOS & Spinrite 6.1 Release 2 to start testing my HHDs. I followed this YouTube video from Tech323_YT which looked like it was exactly what I wanted:

SpineRite Level 5 was running well until it reported several defective (“B”) sectors with “This drive FAILS to report WRITE ERRORS!” warnings. Oh no! However, if I run SpinRite on a PC the HDD passes with flying colours & another HDD (which previously passed L5 on the PC) then starts reporting multiple defective sector warnings on the Zimaboard. Every HDD I test works fine on the PC & has multiple warnings on the Zimaboard.

I swapped the bootable USB thumb drives between the machines but with no change to the above symptoms. Tried different size HHDs from 150GB to 4TB but again no change.

Is there a rookie error I’m making here?

Thanks in advance.
 
Welcome @the_physio

If you re-run the drive on the Zimaboard after the PC does it run into the same trouble?

Are you running the FreeDOS that comes built into the bootable USB or are you using the freedos that you installed on the Zimaboard? They are different, the one that SpinRite preinstalls is customised.
 
Re-running the drive on the Zimaboard after a clear run on the PC still produced the same errors - & vice versa - the problem stays with the Zimaboard.

The FreeDOS is that installed on the Zimaboard - I'll try with the bootable USB & see how that goes & then report back.
 
Used the Zimaboard with a bootable USB from SpinRite 6.1 Rel 2 & it still threw up a huge amount of these critical errors - although when I restart the process they aren't always coming up in the same sectors (see attached)
SpinRite-02a.jpg

SpinRite-03a.jpg

SpinRite-03b.jpg
 
Interesting that everything is repeatable.

Could you run the Diags command while launching Spinrite from both devices.

Code:
SPINRITE.EXE /DIAGS

It should produce some dbg files indicating the process Spinrite uses to detect the drives and controllers. If you can supply them it might help get to the bottom of this one.
 
Seems likely to be a cabling error of some sort if it's that random. Or a power issue. Did you get extra power for the ZimaBoard... I don't believe the supplied power supply is enough for spinning media.
 
As suggested, I’ve tested (SpineRite 6.1 R 2 on Level 5) on a 1TB WD Green HDD using the Zimaboard 216 with DIAGS (refer to 3.DBG & 3.LOG) – plenty of early issues after only 0.3% completed.

Then repeated (same HDD & bootable USB) on a PC with DIAGS (refer to 4.DBG & 4,LOG) – clear of issues after 11% completed. I could test both to completion, but the difference is already very stark.

For the Zimaboard 216 I’m using the supplied 12V/3A Power Adaptor with only the one HDD attached. I do have the SATA Y-Cable but am using the single cable – but regardless the errors occur no matter which SATA cable I use.

If I rerun SpinRite on the Zimaboard a second time it doesn’t produce errors in the same sectors.
 

Attachments

  • 3.DBG.txt
    5.4 KB · Views: 52
  • 3.LOG.txt
    13.7 KB · Views: 51
  • 4.DBG.txt
    2.3 KB · Views: 51
  • 4.LOG.txt
    8.1 KB · Views: 44
You probably need an upgraded power supply, 3A is likely marginal for the setup, as the drive will be drawing a lot of power from the 12V rail to do all the head movements for the test, and you probably want at least a 5A supply to provide the needed power that is stable. 3A is fine for the base board with only a SD card or SSD as drive, but spinning drives do need more current to handle the peaks of starting up the motors and to do head positioning correctly. Upgrade to a 5A or higher 12V supply, or add in a second small supply that provides 12V and 5V to power the drive only.
 
  • Like
Reactions: foreverinbeta
Tested (same HDD & same USB bootable SpinRite 6.1 R2) on the Zimaboard 216 but with the HDD powered from the PC (700W power unit with no other HDDs attached) – the same PC which runs flawlessly.

Sadly, there was no difference (refer to 6.DBG & 6.LOG attached). I really expected this to work.
 

Attachments

  • 6.DBG.txt
    5.4 KB · Views: 46
  • 6.LOG.txt
    39.8 KB · Views: 44
I've read through the entire thread and looked at all of the logs and I agree with everyone that this is a mystery. SpinRite was developed primarily on the ZimaBoard (216) and it's been more heavily tested there than anywhere else. And we're also no stranger to the Western Digital WD10EARS family of drives. It appears that something about THAT ZimaBoard (we don't know about any others) and THAT drive are unhappy with each other.

Tried different size HHDs from 150GB to 4TB but again no change.
And that answers the question about whether the trouble is tied to the drive. It's not.

The logs show that the apparent errors being detected by SpinRite at Level 5 are random. From one run to the next there is no repetition.

What happens at Level 3?

Also, does the ZimaBoard's other SATA connector behave similarly?

And, finally... for diagnostic curiosity, if you had a spare PCIe SATA adapter lying around, you might try plugging it into the ZimaBoard's PCIe connector to see whether that drive attached through a different controller/adapter works as it does on your other PC.

NOTE TO EVERYONE: SpinRite produces the complaint “The drive did not report that it failed to properly write data to this sector.” when a read verification following an error-free write, fails data verification. That error report has not been sitting well with me. It's generated when a multi-sector block read verification—following an inverted or re-inverted write—with the read command succeeding but there being a data miscompare. Since the block read succeeded without ANY complaint, not even an ECC error correction needed, but the data does not compare, SpinRite faults the previous writing action which may have mis-written the testing data without complaint (though write operations do not generally complain since they do not inherently verify).

At this point, I agree that the ZimaBoard itself is suspect.

Once upon a time, the earliest SpinRites used to perform some quick RAM testing. That fell by the wayside through the years since RAM is so rarely troublesome... but this makes me wonder whether perhaps SpinRite itself ought to be verifying the integrity of the multiple very large 16MB buffers that it's using.
 
Thanks Steve – I feel like I’m addressing royalty – I’ll test Level 3 & have a look about for a PCIe SATA adapter to try your other suggestions & report back.

I am slowly drawing the solution that the Zimaboard itself is suspect. One interesting issue was that when I first fired it up & attempted to update the CasaOS it steadfastly refused to do so. I wasn’t overly concerned as I’d always bought it as a SpinRite machine so went through the process of installing FreeDOS as previously mentioned.

I’ll let you know how the Level 3 & possible PCIe SATA goes.
 
I am slowly drawing the solution that the Zimaboard itself is suspect.
Right. These ARE complex systems and it's certainly very possible for some subtle manufacturing error to escape their post-manufacturing testing. If anything, I'm surprised that it doesn't happen more often! My concern here is that the trouble appears to be affecting SpinRite's operation, and in a way that SpinRite MAY be able to detect and protect from. And if so, I would want to do so.

If you can run https://www.memtest86.com/ on that board and find a problem there, THAT would be extremely useful! (y)
 
Okay, an update on today before I hit the sack.

I did run Level 3 on a 500GB HDD which finished completely error free.

I also started a Level 4 test & aborted after 29% completed after 2 errors both “The drive did not report that it failed to properly write data to this sector…”.

Just for completeness I also started a Level 5 test & aborted after 8% completed after 9 errors – same as above but in different sectors to the Level 4 test.

I haven’t been able to source a PCIe SATA adapter, so no test in that regard.

I’ve kicked off a MemTest86 which is still running – so far 1 error reported. FYI, I've just run the first optioned test so let me know if there's something in particular I need to specify. While I probably know more about this stuff than my health care workmates I'm definitely not a geek/guru/nerd - so bear with me. ;)

I’ll update the full MemTest86 results tomorrow – probably after I get home from work (down-under time). Thanks for your input & assistance.
 
I’ve kicked off a MemTest86 which is still running – so far 1 error reported.
HOLY CRAP!! THAT SHOULD NEVER HAPPEN!! I have NEVER seen MemTest86 generate a single error.
Wow. This changes my planned next project... SpinRite needs to verify, as best it's able, the safety of machine's RAM for holding data.
I've never explored MemTest86 deeply, but it appears able to generate an report of its findings. That would be good to have.

UPDATES:
  1. I have MemTest86 running on one of my ZimaBoards.
  2. The documentation indicates that when the test is completed you will be given the opportunity to save the results to an HTML file. PLEASE do save the results, and share them here. THANK YOU!
  3. (7:20am) The full default 1st pass on my ZimaBoard 216 required ~48 minutes. (No errors found.)
  4. (8:55am) In pass #3, no errors found.
  5. (9:36am) Stopped before the end of pass #3 (since I want to use the ZimaBoard). I saved the MemTest86 HTML report then shutdown the ZimaBoard. The HTML file is written into the: /EFI/BOOT/ directory. Mine was 22K and is a nicely formatted standalone HTML file. PLEASE do save one and share it! Thanks!
@the_physio: I imagine you would like to have a functioning ZimaBoard. But your apparently defective ZimaBoard is valuable to this project. So rather than having you return it to ZimaLand, I would be glad to purchase a replacement ZimaBoard and have it sent to you if you'll send your defective ZimaBoard to me. There's no hurry here and I expect that I may be able to arrange to have SpinRite run on your ZimaBoard by having it intelligently use a different region of RAM after testing a region and finding trouble there. I'll have a new release of SpinRite for you to test. I just wanted to put this out there so that this defective board was not returned. (y)
 
Last edited:
  • Like
Reactions: SeanBZA
It's my previous PC. I originally built it with 32 GB of RAM, and it worked great. After a few years I decided to upgrade to 64 GB by buying the same kit of RAM, 2 16 GB sticks. I don't remember how long it took, but I eventually started noticing strange behavior, and I think I even had a corrupt file. I think I ran it like that for a few months before I decided to run MemTest86. I was actually able to get the full 64 GB to pass MemTest86 by lowering the RAM speed from 3200 to 3000 in the BIOS.

Due to this experience, I will ALWAYS test every computer before I use it. My new computer passed with flying colors :)
 
Last edited: