Pending Invalid Opcode

  • Be sure to checkout “Tips & Tricks”
    Dear Guest Visitor → Once you register and log-in:

    This forum does not automatically send notices of new content. So if, for example, you would like to be notified by mail when Steve posts an update to his blog (or of any other specific activity anywhere else), you need to tell the system what to “Watch” for you. Please checkout the “Tips & Tricks” page for details about that... and other tips!

    /Steve.

lawson23

Member
Jan 10, 2021
5
1
Tried running Read Speed and as soon as I executed (after it booted from USB) it I got "Invalid Opcode at F087 0000 0006 0076 Fx6C 00D9 0169 050C 0046 F006 0000 0006 00"

scrolling across the screen. Everything was the same but the x which changed with every line.

I let it sit there and finally it stopped with a bunch of wingding characters after the Invalid Opcode ....

Ideas the motherboard is a Gigabyte MA770-UD3
 

millQ

Member
Oct 20, 2020
22
7
Did it crash after the splash screen(after you pressed enter) or you pressed Escape and then typed rs?

Did you use Readspead.exe to boot prep the USB stick?
 
Last edited:

lawson23

Member
Jan 10, 2021
5
1
Yes the usb boots the splash screen comes up and when I hit enter it just scrolls and scrolls the errors. I have a few pictures if needed.
 

AlanD

Well-known member
Sep 18, 2020
210
69
Rutland UK
Boot from the USB, but press Escape as soon as it is booted. See if you get a C:\ DOS prompt. If so, try running ReadSpeed by typing "rs.exe" on the command line. That might identify if it is a problem with the application itself, or the splash screen/menu.
 

Steve

(as in GRC)
Staff member
Feb 1, 2019
375
1
996
66
Southern CA, USA
www.grc.com
Yes the usb boots the splash screen comes up and when I hit enter it just scrolls and scrolls the errors. I have a few pictures if needed.
Hi @lawson23 : The most likely cause of this is a problem with the creation of the bootable filesystem. Could you try recreating the USB stick, and/or do you have another USB drive that you could try? Thanks!!
 
  • Like
Reactions: Barry Wallis

lawson23

Member
Jan 10, 2021
5
1
@Steve I will give this a shot
@AlanD I was able to get dos successfully but upon running rs.exe the first time I got a ReadSpeed two line banner then under it Divide error and a dos prompt again so I kicked off rs.exe again and got the invalid opcode error but it did not scroll like the other execution only two lines of the error.

Going to try rebuilding and see what happens. Thanks everyone
 
  • Like
Reactions: Steve

Richard

Member
Sep 18, 2020
8
2
Also:

1) What is the result if you boot your USB drive, press <Esc>, then run rs /hashonly ?

2) Go to https://www.grc.com/sr/faq.htm and follow the "How do I make a bootable USB thumb drive??" instructions to make an MS-DOS, not freedos, bootable USB drive. Put rs.exe on it and run it. What happens?

I have an ASRock motherboard very similar to yours running a Phenom CPU. Maybe we have an oddball drive chipset. It has an "Invalid Opcode" the second time I run rs.exe under freedos but not MS-DOS. Running DrivEnum.exe before each rs.exe run prevents the crash. Running rs /hashonly prevents the crash.

I've reported the problem but it hasn't been fixed because it happens on only 1 computer. It will make SpinRite more reliable if it is observed on enough computers to warrant fixing.
 

lawson23

Member
Jan 10, 2021
5
1
@Richard
First post running DrivEnum.exe works but running RS.exe after produces divide error then if executing it again I get the invalid Opcode - yes running a Phenom CPU
Second post rs /hashonly even when running drivenum before produces divide error then if executing it again it drops a line in dos like it is running but just sits there and left it for like 5 minutes and no changes.
I'm now working on the ms-dos test so will get back to you.
MS-DOS test I can run drivenum. Then I execute rs.exe /hashonly and get "program caused a devide overflow"
if I run rs.exe a second time it just locks up and no invalid opcode error but is locked up.
 
Last edited:

Richard

Member
Sep 18, 2020
8
2
@lawson23

Thank you very much.

What happens if you:
1) Under MS-DOS don't run DrivEnum and just run rs (without /hashonly)? Twice?
2) Under MS-DOS run pci.exe?
3) Download RS-49k.EXE from https://www.grc.com/dev/SpinRite/ and run it under MS-DOS? Twice?

Your and my motherboards are very similar because they support AMD Athlon and Phenom CPUs, in either Socket AM2+ or Socket AMD3. They use DDR2 when DDR3 had become common.
Yours https://www.gigabyte.com/us/Motherboard/GA-MA770-UD3-rev-21#ov
Mine http://www.asrock.com/mb/AMD/A785GM-LE/

I think rs.exe crashes on both our motherboards because their chipsets do something that rs.exe isn't yet programmed to expect.