Initdisk getting Windows error code: 0x015

  • SpinRite v6.1 Release #3
    Guest:
    The 3rd release of SpinRite v6.1 is published and may be obtained by all SpinRite v6.0 owners at the SpinRite v6.1 Pre-Release page. (SpinRite will shortly be officially updated to v6.1 so this page will be renamed.) The primary new feature, and the reason for this release, was the discovery of memory problems in some systems that were affecting SpinRite's operation. So SpinRite now incorporates a built-in test of the system's memory. For the full story, please see this page in the "Pre-Release Announcements & Feedback" forum.
    /Steve.
  • Be sure to checkout “Tips & Tricks”
    Dear Guest Visitor → Once you register and log-in please checkout the “Tips & Tricks” page for some very handy tips!

    /Steve.
  • BootAble – FreeDOS boot testing freeware

    To obtain direct, low-level access to a system's mass storage drives, SpinRite runs under a GRC-customized version of FreeDOS which has been modified to add compatibility with all file systems. In order to run SpinRite it must first be possible to boot FreeDOS.

    GRC's “BootAble” freeware allows anyone to easily create BIOS-bootable media in order to workout and confirm the details of getting a machine to boot FreeDOS through a BIOS. Once the means of doing that has been determined, the media created by SpinRite can be booted and run in the same way.

    The participants here, who have taken the time to share their knowledge and experience, their successes and some frustrations with booting their computers into FreeDOS, have created a valuable knowledgebase which will benefit everyone who follows.

    You may click on the image to the right to obtain your own copy of BootAble. Then use the knowledge and experience documented here to boot your computer(s) into FreeDOS. And please do not hesitate to ask questions – nowhere else can better answers be found.

    (You may permanently close this reminder with the 'X' in the upper right.)

Jeff Dunn

Member
Oct 5, 2020
14
2
My USB thumb drive is recognized under Linux but it will not allow me to format it. So I tried initdisk and got the Windows error code: 0x015 looking for ideas ? If no good ideas I will just buy a new one
 
Huh. Could you take a photo and attach it to a Twitter message. I'll go look for it. Note that I don't actually use Twitter at all in any way during the week. I only go there Monday when I'm collecting feedback. :) Thanks!
 
Here is a screen shot
initdiskError3.jpg
 
Not sure if this matters, but I was using the drive with Ventoy and I had just copied a iso file and selected safely remove and it was ok to remove it. I tried chkdsk and got an error raw disks are not supported.
 
Hey Jeff. The line above that “The device is not ready” provides the most info.

What else are we seeing on the screen? Is this a true Native Windows running on hardware? Or are you doing something fancy with VM's or something? InitDisk uses VERY low-level access APIs to do what it does. So if the environment is virtualized or otherwise "fancy" somehow, that could be the cause of the trouble?
 
Well I ran ValiDrive on this USB drive awhile back when validrive was released and it matched the drive specs. I just tried it again and it failed
1709226523777.png

1709226547628.png
 
Which is what I thought, so I ordered a replacement. I will keep the broken around to test on any new versions of initdrive.

But thanks for your time