InitDisk created a zero-size thumb drive?

  • SpinRite v6.1 Release #3
    Guest:
    The 3rd release of SpinRite v6.1 is published and may be obtained by all SpinRite v6.0 owners at the SpinRite v6.1 Pre-Release page. (SpinRite will shortly be officially updated to v6.1 so this page will be renamed.) The primary new feature, and the reason for this release, was the discovery of memory problems in some systems that were affecting SpinRite's operation. So SpinRite now incorporates a built-in test of the system's memory. For the full story, please see this page in the "Pre-Release Announcements & Feedback" forum.
    /Steve.
  • Be sure to checkout “Tips & Tricks”
    Dear Guest Visitor → Once you register and log-in please checkout the “Tips & Tricks” page for some very handy tips!

    /Steve.
  • BootAble – FreeDOS boot testing freeware

    To obtain direct, low-level access to a system's mass storage drives, SpinRite runs under a GRC-customized version of FreeDOS which has been modified to add compatibility with all file systems. In order to run SpinRite it must first be possible to boot FreeDOS.

    GRC's “BootAble” freeware allows anyone to easily create BIOS-bootable media in order to workout and confirm the details of getting a machine to boot FreeDOS through a BIOS. Once the means of doing that has been determined, the media created by SpinRite can be booted and run in the same way.

    The participants here, who have taken the time to share their knowledge and experience, their successes and some frustrations with booting their computers into FreeDOS, have created a valuable knowledgebase which will benefit everyone who follows.

    You may click on the image to the right to obtain your own copy of BootAble. Then use the knowledge and experience documented here to boot your computer(s) into FreeDOS. And please do not hesitate to ask questions – nowhere else can better answers be found.

    (You may permanently close this reminder with the 'X' in the upper right.)

Sam4Squirrel

Member
Dec 30, 2020
5
2
After formatting with InitDisk, an 8GB Kingston DataTraveller "100 G2" drive reports zero size and cannot be read by Windows 10.

I have a 2012-vintage Kingston USB flash drive. I recently used it to create a Linux boot disk, with the Rufus utility. And that worked fine.
But Win10 couldn't read the drive anymore.
So, I tried to recover it with GRC's InitDisk utility.
And InitDisk worked fine. I ran it under Win10, with "Run as administrator", I plugged in the drive, InitDisk identified the drive, and formatted the drive.

But, after formatting with InitDisk, the drive isn't recognized as storage media anymore.
InitDisk no longer recognizes the drive when it's plugged in.
Win10 takes a long time (just over 20 seconds) to assign the drive a letter after it's plugged in.
When it does assign a drive letter, the drive shows up with zero size.
And the "INITDISK" volume label is not present on the drive.

So, the two questions are:
#1: What's up with this?
And, #2: How can I recover the drive?

(My traditional answer to #2 has been: Plug it in to a Linux system and use gparted to blow away the partition table and write a new one.
But, I'll hold off on that in case any other InitDisk/SpinRite users find this case interesting.)

I'm attaching several screenshots. These are:
Win10 drive Properties, showing zero size.
Device Manager's Device Properties view of the drive, showing that it's populated with one, zero MB volume.
DiskPart (Win10's new replacement for fdisk), showing listings of my drives and volumes (note: no volume label on the USB drive).
DiskPart's "detail disk" output, showing "Status: No Media".
DiskPart's "detail volume" output, showing "Virtual Disk Service error: There is no media in the device."

Those strike me as very strange errors. This drive does not have removable media. It is a removable drive, with fixed flash media.

Any advice? Any additional diagnostics I should collect?

Let me know...
 

Attachments

  • Zero_Size_D_Drive.jpg
    Zero_Size_D_Drive.jpg
    26.7 KB · Views: 375
  • Zero_Size_D_Drive_Device_Properties.jpg
    Zero_Size_D_Drive_Device_Properties.jpg
    29.7 KB · Views: 356
  • Zero_Size_D_Drive_DiskPart_DriveDetail.jpg
    Zero_Size_D_Drive_DiskPart_DriveDetail.jpg
    49.9 KB · Views: 355
  • Zero_Size_D_Drive_DiskPart_list.jpg
    Zero_Size_D_Drive_DiskPart_list.jpg
    61.7 KB · Views: 347
  • Zero_Size_D_Drive_DiskPart_VolumeDetail.jpg
    Zero_Size_D_Drive_DiskPart_VolumeDetail.jpg
    61.1 KB · Views: 344
Last edited:
It looks like something in the file system format got corrupted. Also, the flash drive is now 8 years old. It could be just starting to die by now, depending on the build quality and how much it's been used.
 
DanR, yeah, I used the latest. Freshly downloaded tonight. R5.

JulioHM, The drive hasn't seen a lot of use. It sat idle for about 7 years, "archiving" an old Ubuntu 11-era bootable installer.
I bought several identical drives at that time. The others all appear to be in good health.
So, I have the opportunity to try InitDisk again, with another drive of the same type.
But, before I do that, I'd like some assurance that it won't brick the next drive, too...
 
I think it very very unlikely that InitDisk harmed your USB flash drive. It seems likely that your UBS drive simply died at this time.

For the past 8 months or so I have been a participant in the AHCI/InitDisk/ReadSpeed development activity over in the development newsgroup. There have been *NO* instances of any of this activity damaging a USB flash drive. There have been instances of InitDisk not always working properly. After Steve figured out why and made the necessary tweaks to his code, the result was a new release of InitDisk (and an improved ReadSpeed). Hence we are at InitDisk 5.0 today.

I would suggest giving @Steve a chance to see and respond to this thread.
 
@Sam4Squirrel : Thanks for posting such truly useful data about your situation. I have to agree with DanR and DarkwinX on this one. Thanks to your posting the output of DISKPART. There's no way that anything written to the drive could cause it to show 0 bytes of physical size since that's coming from a level below any data contained on the drive.

I strongly dislike coincidences, since I tend not to believe in them, and they are impossible to prove. But in this case, I think that it was a coincidence that it was while using InitDisk that the drive decided that it would rather be inert.
 
Update:
The drive shows signs of life.

I've done nothing to it since Wednesday. So, I certainly didn't fix the thing.
I put my Win10 laptop through a couple hibernate/restore cycles. But I haven't rebooted it.

And, today, Win10 shows my thumb drive in Explorer, with the expected "INITDISK R5" volume name.
Today, Rufus knows that it's an 8GB device.

But, right-clicking on it in the left-hand Navigation pane of an Explorer window crashes Explorer.
All of my open Explorer windows vanish. And my task bar "blinks" out of existence and reappears.
I've learned that this is what it looks like when Explorer crashes under Win10. And it's 100% repeatable.

Very strange behavior.
Could this just be the vicissitudes of Windows 10?
Was Windows Explorer also just that done with 2020, that it was waiting for the new year to read my drive?
Or, maybe the drive hardware is flaking out, after all.
 
Rufus successfully reformatted the drive and installed its built-in "FreeDOS" image.
After that, I could browse the drive in Windows Explorer.

But, even after a reboot, a right-click on any item in any Explorer window's Nagivation pane immediately crashes Explorer.
That happens whether the drive is plugged in or not.

Whatever this is, it doesn't appear related to InitDisk.

Thanks to all of you for reading.
 
  • Like
Reactions: Steve and DarkwinX