Incontrol

  • Release Candidate 6
    Guest:
    We are at a “proposed final” true release candidate with nothing known remaining to be changed or fixed. For the full story, please see this page in the "Pre-Release Announcements & Feedback" forum.
    /Steve.
  • Be sure to checkout “Tips & Tricks”
    Dear Guest Visitor → Once you register and log-in:

    This forum does not automatically send notices of new content. So if, for example, you would like to be notified by mail when Steve posts an update to his blog (or of any other specific activity anywhere else), you need to tell the system what to “Watch” for you. Please checkout the “Tips & Tricks” page for details about that... and other tips!

    /Steve.
  • Announcing “BootAble” – GRC's New Boot-Testing Freeware
    Please see the BootAble page at GRC for the whole story.
  • BootAble – FreeDOS boot testing freeware

    To obtain direct, low-level access to a system's mass storage drives, SpinRite runs under a GRC-customized version of FreeDOS which has been modified to add compatibility with all file systems. In order to run SpinRite it must first be possible to boot FreeDOS.

    GRC's “BootAble” freeware allows anyone to easily create BIOS-bootable media in order to workout and confirm the details of getting a machine to boot FreeDOS through a BIOS. Once the means of doing that has been determined, the media created by SpinRite can be booted and run in the same way.

    The participants here, who have taken the time to share their knowledge and experience, their successes and some frustrations with booting their computers into FreeDOS, have created a valuable knowledgebase which will benefit everyone who follows.

    You may click on the image to the right to obtain your own copy of BootAble. Then use the knowledge and experience documented here to boot your computer(s) into FreeDOS. And please do not hesitate to ask questions – nowhere else can better answers be found.

    (You may permanently close this reminder with the 'X' in the upper right.)


colin.p

Member
Jun 30, 2021
7
3
A year ago, I bought a windows 10 "refurb" computer and decided to keep windows on it, as I haven't used windows since the XP days. When I used XP, I always tinkered with security settings and frequented GRC back in the usenet days (my brain is a bit foggy as most of the '80's, '90's and early naughts are a blur).

I like the idea of keeping 10 (11 is not supported, thank goodness) as it is and just updating the really needed stuff. However, while reading a thread on another forum, I checked my activation status and noticed a line that says something like: "The last product key (id:*****-*0000-00000-AAOEM) you entered can't be used on this copy of Windows (0x********). I have replaced some of the numbers/letters with *.

Now I have no idea as to why it would tell me that I put in the wrong product key, and as to my somewhat shaky memory, I do not recall ever trying to change my key.

The error message was only noticed now and was not there the last time I was in the Activation window, but I have only recently used Incontrol (so, of course it seems like it's the "suspected" suspect as unlikely as that may be). So my question is: How does Incontrol work and in order to keep windows from upgrading, does it somehow put in a fake product key to stop the upgrade?

If the answer is that Incontrol does not try to change the key and I'm way off base, then I have more sleuthing to do, and will move along to find the culprit.

edit to add: The error message doesn't seem to change anything in the way the computer operates, and windows still indicates it's properly activated to my MS account, but I'm curious as to what or who may have tried inputting a different key.

edit to add actual error code:
actual number: 00330-50000-00000-AAOEM (0x8007045B)
 
Last edited:
How does Incontrol work and in order to keep windows from upgrading, does it somehow put in a fake product key to stop the upgrade?
Nope! InControl does nothing with activation keys.

InControl only checks and sets a few registry keys to prevent undesired upgrades from Windows 10.

InControl's registry tweaks can be easily and cleanly undone by re-running the tool and clicking the "Release Control" button.

No activation keys are ever affected by InControl.
 
  • Like
Reactions: colin.p
Thanks for the reply and that was what I was more or less expecting. I guess I have some work cut out for me to find the true culprit.
 
The error message doesn't seem to change anything in the way the computer operates, and windows still indicates it's properly activated to my MS account, but I'm curious as to what or who may have tried inputting a different key.

YW!

I'm guessing that this error message might go all the way back to when this device was re-furbished before you acquired it. If the valid code was typo-ed when first entered, this message would occur. Re-entering the code correctly would successfully complete the activation. And for some reason the now no longer valid error message was needlessly retained?

In any case, your Windows activation appears to be fully functional. Nothing broken = Nothing to be fixed

One more thought: If an invalid code is entered on a fully activated system, that code would be rejected and the activation not affected/changed. Hence the error message?
 
  • Like
Reactions: colin.p
Yes it is activated with a digital license, and still says so. Of course I could be wrong and it always had that error message but I'm pretty sure it's only fairly recently appeared. I won't stress too much about it and keep an eye on it.

Thanks for the replies.
 
I won't stress too much about it and keep an eye on it.
This utility may provide you with some interesting information (Nir Sofer is a well regarded developer of Windows utilities).
 
  • Like
Reactions: colin.p
From my nosing around and doing a better Google Search I found pretty well what DanR said. As long as MS says that win 10 is activated and linked with my MS account, I'm good. It's still a little unclear as to who/what inputted in a wrong key, but nothing seems to be damaged. All info tells me to disregard the error message and carry on.

Paul F I'll try that Key Scanner for Windows but I'm not sure if it will show the proper key with a digitally linked account, but it might shed a little light on whatever caused it. Nothing ventured nothing gained I guess,

edit (again): I added the actual key number, as well as the error number as I was told (windows10 forum) that it is just a generic number and shows up in Google search as an error key number anyway
actual number: 00330-50000-00000-AAOEM (0x8007045B)
 
Last edited:
I had a similar issue crop up on a Windows 7 system, where I had upgraded the hard drive to a 1 TB 'monster' compared to the original drive that had come in the laptop. What I didn't know was that a subtle issue in the BIOS was screwing up the logical block drive mapping, such that I could use the hard drive utility that came with the new drive to copy over all the data from the old drive, and it would run for a while (days, weeks?) and then suddenly start showing 'you are not running a genuine version of Windows' messages, and other errant behavior, like not letting me using Microsoft Update to get security fixes and updates.

After doing some Googling around, I found an Intel chipset driver (on the Intel site) that among other things purported to support large drives. By installing this, I was able to get the system to run better for some period of time, but eventually, the drive would start to deteriorate, apparently with errant block mappings, and things would just go to hell in a hand basket, again.

After dealing with this for a while (it was a secondary laptop, used only in my ham shack for running digital modes and logging), I finally gave up and bought a refurbished newer laptop that came with Windows 10 Pro pre-installed, and never looked back. That old Win7 laptop had run like a top for me for many years, but the manufacturer decided it was too old to write Windows 10 compatible drivers for it, so when Windows 7 went out of support, I was forced to give it up.

All but one of the laptops my wife and I use now are refurbished off-lease laptops. They run fine, and cost a fraction of new ones that are only about a year or two newer. The ham shack laptop is now a quad-core i7 with 16GB memory and came with a 256 GB SSD, for about $250. I swapped the SSD for a 1 TB SSD for less than $100, and I'm in business. It even sports a TPM, although it is currently running 1.2, there is a script available to update it to 2.0, so when Windows 10 goes out of support in three years, I should be able to upgrade it to Windows 11.

Who knows? Windows 11 might be stable enough to run in a few years....
 
  • Like
Reactions: colin.p
Be aware that if you updated your version of Windows (for free) from say 7 or 8 to 10, that you do not have a valid license key, even if you attempt to extract it. The license key, if any, is stored on Microsoft's activation servers (the digital license/entitlement) and whatever you will extract from Windows is not a license you can give back to it in the future. (You would need to give it back the original Windows 7 or 8 license, but why would you if you have the entitlement... you just say you don't have the license and it will check for the entitlement later and everything "just works" unless you've made significant changes to the PC. In that case, the theoretical fix is to tie your entitlement to a Microsoft Account (MSA) before you make the changes.)