CHUWI GemiBook XPro - no video

  • SpinRite v6.1 is Released!
    Guest:
    That's right. SpinRite v6.1 is finished and released. For the full story, please see this page in the "Pre-Release Announcements & Feedback" forum.
    /Steve.
  • Be sure to checkout “Tips & Tricks”
    Dear Guest Visitor → Once you register and log-in:

    This forum does not automatically send notices of new content. So if, for example, you would like to be notified by mail when Steve posts an update to his blog (or of any other specific activity anywhere else), you need to tell the system what to “Watch” for you. Please checkout the “Tips & Tricks” page for details about that... and other tips!

    /Steve.
  • Announcing “BootAble” – GRC's New Boot-Testing Freeware
    Please see the BootAble page at GRC for the whole story.
  • BootAble – FreeDOS boot testing freeware

    To obtain direct, low-level access to a system's mass storage drives, SpinRite runs under a GRC-customized version of FreeDOS which has been modified to add compatibility with all file systems. In order to run SpinRite it must first be possible to boot FreeDOS.

    GRC's “BootAble” freeware allows anyone to easily create BIOS-bootable media in order to workout and confirm the details of getting a machine to boot FreeDOS through a BIOS. Once the means of doing that has been determined, the media created by SpinRite can be booted and run in the same way.

    The participants here, who have taken the time to share their knowledge and experience, their successes and some frustrations with booting their computers into FreeDOS, have created a valuable knowledgebase which will benefit everyone who follows.

    You may click on the image to the right to obtain your own copy of BootAble. Then use the knowledge and experience documented here to boot your computer(s) into FreeDOS. And please do not hesitate to ask questions – nowhere else can better answers be found.

    (You may permanently close this reminder with the 'X' in the upper right.)


ColbyBouma

Well-known member
Dec 26, 2020
132
54
This laptop uses AMI UEFI. I enabled CSM and Legacy boot options. When I boot it to my InitDisk flash drive, the screen stays black. It booted successfully though, because when I do things like ECHO HELLO > CHUWI.TXT, that file gets created. I tried running MODE 80, but nothing happened. Legacy USB support is enabled by default.

This thing has hundreds of UEFI settings I can tweak, many of which cause it to no longer POST. I've had to pull the battery a few times. One of the options that breaks it is the Video Option ROM. It defaults to UEFI, and changing it to Legacy completely disables video output (can't even get back into the UEFI menu). Am I correct in assuming that this is the critical setting that's keeping me from getting video output in FreeDOS, or could it be one of the other settings?

I've tried running SpinRite, but the screen stays blank, and no log is created. The most I've gotten is an empty DBG file with PR506 DIAGS VIDEO AUTO EXIT LEVEL 1 NEVER TYPE AHCI #0 #0.